Login Registre-se
SCAN - Erro ao consultar recibo  XML
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Autor Mensagem
leopoldof

JavaC Membro

Membro desde: 14/02/2012 11:57:42
Mensagens: 100
Offline

Boa tarde senhores...
Estou implementando o módulo de SCAN...

O sistema envia a nfe em modo scan certinho, e retorna a resposta cstat = 103 - xMotivo = Lote recebido com sucesso
Porém...quando vou buscar o recibo, me retorna a mensagem cstat = 999 xMotivo = "2999 - Falha nao tratada"

Todas as vezes...o que pode ser isso? alguém já passou por isso?...Erro no xml não pode ser, senão não passaria nem na validação do xml
FernandoTriade

JavaC Membro
[Avatar]

Membro desde: 01/07/2011 18:18:18
Mensagens: 38
Localização: Aracaju-SE
Offline

Olá leopoldof, tudo certim?

Alguns testes que eu faria nesse caso e que tem ocorrido com muita gente aqui no fórum:

1 - Está aguardando o tempo necessário antes de efetuar a consulta do recibo? (alguns processos exigem tempo mínimo, vide manual)

2 - Validou o XML de consulta do recibo? (aqui no fórum tem tópicos sobre isso e existem alguns portais que fazem essa validação, RS por exemplo)

3 - Houve um caso aqui no fórum que foi preciso entrar em contato com a respectiva SEFAZ, pois no caso específico do erro 999, era falha na recepção do XML (dá uma pesquisada aqui na comunidade)

Caso alguém tenha mais sugestões, favor colaborar.

Abraços,

Fernando Santos
[WWW] [MSN]
leopoldof

JavaC Membro

Membro desde: 14/02/2012 11:57:42
Mensagens: 100
Offline

Olá...obrigado por responder....

estou quebrando a cabeça aqui...mas realizei os testes sujeridos..

1 - Está aguardando o tempo necessário antes de efetuar a consulta do recibo? (alguns processos exigem tempo mínimo, vide manual)

Sim... na verdade...espero um tempo e mando o pedido de recibo...caso retorne com a resposta de "Lote em processamento" , o sistema espera mais um pouco e reenvia o pedido
E as vezes ocorre de vir isso.. e tudo funciona...

2 - Validou o XML de consulta do recibo? (aqui no fórum tem tópicos sobre isso e existem alguns portais que fazem essa validação, RS por exemplo)

Validei...mas vou re-validar novamente para ver...vai saber ...he he he

3 - Houve um caso aqui no fórum que foi preciso entrar em contato com a respectiva SEFAZ, pois no caso específico do erro 999, era falha na recepção do XML (dá uma pesquisada aqui na comunidade)

Estou desconfiado que não seria na consulta do recibo em si....mas sim no envio da nfe para o SCAN .. vou re-verificar todo o módulo de geração e envio da nfe para ver...pois pelo que deu para perceber, está dando erro ao validar a nfe e não ao consultar o recibo....pois implementei agora a consulta de nfe e nfe-scan...e a nota enviada não existe em nenhum dois dois WS...

Obrigado pelas dicas...vou verificar aqui...e assim que achar a solução...posto aqui...


leopoldof

JavaC Membro

Membro desde: 14/02/2012 11:57:42
Mensagens: 100
Offline

Boa tarde a todos.....
Creio que descobri o motivo do problema...
Fuçando pela net, achei num fórum alguém que estava passando pelo mesmo problema que eu...
O problema se dá quando tento enviar uma nfe com numeração duplicada.... e ao invés de retornar a mensagem de duplicidade de nfe, retorna essa mensagem maluca que citei anteriormente
 
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Ir para:   
Powered by JForum 2.1.9 © JForum Team