Login Registre-se
Erro ao tentar consumir WS  XML
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Autor Mensagem
vinnykrs

JavaC Membro

Membro desde: 03/10/2012 11:03:03
Mensagens: 78
Localização: Assis, São Paulo
Offline

Estou com um erro aqui, mas não to conseguindo saber o que ta acontecendo..

Nos outros computadores está normal, só em um cliente que trabalha por acesso remoto ao servidor que está dando isso.


Alguém poderia ajudar ? ;s
[MSN]
Quasar

JavaC Membro

Membro desde: 15/06/2012 09:57:00
Mensagens: 52
Offline

Provavelmente vc invocou metodos de uma classe cuja instancia não existe.

nfe.builders.SocketFactoryDinamico .... q classe eh essa?
vinnykrs

JavaC Membro

Membro desde: 03/10/2012 11:03:03
Mensagens: 78
Localização: Assis, São Paulo
Offline

Essa é a classe que o Maciel disponibilizou no fórum em Resolvendo o Problema 403.7 Forbidden para Certificado A3 (ProtocolSocketFactory)
[MSN]
vinnykrs

JavaC Membro

Membro desde: 03/10/2012 11:03:03
Mensagens: 78
Localização: Assis, São Paulo
Offline

Cara, o cliente tá parado ( ainda no ultimo dia do mês )

Será que ninguém saberia pelo menos alguma tentativa pra eu tentar aqui ?
[MSN]
jeroqueiroz

Moderador
[Avatar]

Membro desde: 11/06/2011 09:45:18
Mensagens: 1348
Localização: Bahia
Offline

Explique mais como é este cliente seu esta usando este recurso? Fale sobre o funcionamento com este acesso remoto para tentar ajudar.

Jeremias Santos
Seguir no Twitter @jeroqueiroz
Blog Jeroqueiroz


Projeto NF-e, CT-e, CC-e? Comece Por Aqui!


Membros do fórum,

Usem a tag [code] e [/code] quando postarem Códigos Java e ou exemplos de XMLs.
Evitem tópicos duplicados.
Tópico solucionado? Edite o primeiro post e coloque [RESOLVIDO] no final do título.
Evitem reviver tópicos antigos.

O tópico resolveu seu problema? Seja gentil, comente e ou agradeça quem contribuiu com a solução.

Obrigado!
[Email] [WWW] [Yahoo!] [MSN]
vinnykrs

JavaC Membro

Membro desde: 03/10/2012 11:03:03
Mensagens: 78
Localização: Assis, São Paulo
Offline

Bom é assim, o acesso é feito via RDP a um único servidor que está o software e eles...
A aplicação estava funcionando direitinho até cerca de 17h00 da quinta feira passada, só estavam reclamando que não estava imprimindo (creio que não seja nada a ver com a aplicação, pois não imprimia nem do pdf gerado), eles usam como servidor com windows 2003 server que é uma outra empresa que dá manutenção e depois das 17h00 de quinta a aplicação não funcionava mais...
Após muito estresse, dor de cabeça e correr atrás dos técnicos dessa empresa, um técnico disse que meu programa não roda no 2003 server. Mas obviamente que ele está querendo enganar a nós e ao cliente pois ESTAVA funcionando até as 17h00 e além disso entramos por RDP em outro cliente que sabiamos que tinha windows 2003 server e funcionou perfeitamente...
[MSN]
jeroqueiroz

Moderador
[Avatar]

Membro desde: 11/06/2011 09:45:18
Mensagens: 1348
Localização: Bahia
Offline

Não houve nenhuma remoção da cadeia de certificados?

Já fez instalação dos certificados neste servidor?

Fizeram alguma atualização nele ou até mesmo algum tipo de restore?

Jeremias Santos
Seguir no Twitter @jeroqueiroz
Blog Jeroqueiroz


Projeto NF-e, CT-e, CC-e? Comece Por Aqui!


Membros do fórum,

Usem a tag [code] e [/code] quando postarem Códigos Java e ou exemplos de XMLs.
Evitem tópicos duplicados.
Tópico solucionado? Edite o primeiro post e coloque [RESOLVIDO] no final do título.
Evitem reviver tópicos antigos.

O tópico resolveu seu problema? Seja gentil, comente e ou agradeça quem contribuiu com a solução.

Obrigado!
[Email] [WWW] [Yahoo!] [MSN]
vinnykrs

JavaC Membro

Membro desde: 03/10/2012 11:03:03
Mensagens: 78
Localização: Assis, São Paulo
Offline

jeroqueiroz wrote:Não houve nenhuma remoção da cadeia de certificados?

Já fez instalação dos certificados neste servidor?


Isso já está tudo correto.

jeroqueiroz wrote:Fizeram alguma atualização nele ou até mesmo algum tipo de restore?

"Dizem" que não


Agora fiz um outro teste, percebi que o arquivo cacerts do cliente estava com um tamanho diferente do meu (mesmo eu não tendo mexido em nada), assim baixei o cacerts do cliente e testei uma consulta situação de serviço e deu o mesmo erro de lá, quando uso o meu não dá o erro, nessa hora fiquei bem contente pensando ter conseguido desvendar o mistério e enviei o cacerts correto pra lá, e pra minha surpresa não deu certo de novo "/..

Será que pode ter algum anti virus (ou virus) que está modificando o arquivo cacerts (e é só ele ) ou o próprio filezilla que altera alguma coisa?

Obrigado
[MSN]
 
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Ir para:   
Powered by JForum 2.1.9 © JForum Team