Login Registre-se
Rejeição ao acessor Web Service RetRecepcao  XML
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Autor Mensagem
rafael.paz

JavaC Membro

Membro desde: 21/01/2013 10:53:57
Mensagens: 17
Offline

Pessoal, ao acessar o webservice RetRecepcao passando o número do protocolo que recebi do envio do lote recebo um xml com o seguinte erro:


Dei uma pesquisada aqui no fórum e no google, e o pessoal está explicando que não deve haver espaço entre as tags. Eu até utilzei um método que o maciel postou para tirar os espaços em branco entre as tags, porém o erro continua o mesmo.

Se você repararem na mensagem de retorno irão reparar que no final da frase menciona o elemento enviNFe (Elemento: enviNFe), porém em minhas buscas pelo google e aqui no fórum, esse erro 588 não apresenta "(Elemento: enviNFe)" no final da frase de rejeição, ou seja a frase normalmente é a seguinte :"Nao eh permitida a presenca de caracteres de edicao no inicio/fim da mensagem ou entre as tags da mensagem" e não "Nao eh permitida a presenca de caracteres de edicao no inicio/fim da mensagem ou entre as tags da mensagem (Elemento: enviNFe)" como essa que recebi, por isso tô achando estranho. Estou até pensando que pode ser o xml de envio de lote que não estava ok, porém ao mesmo tempo fico pensando, se não estava ok, porque eu recebi uma mensagem do webservice informando que estava ok?
Alguém tem alguma idéia do que eu estaria fazendo errado?

Ah, o xml que envio para o webservice da RetRecepcao é o seguinte:


Como vocês podem ver, ele não tem espaço entre as tags.

Meu código de para se conectar com o webservice é o seguinte:

vinnykrs

JavaC Membro

Membro desde: 03/10/2012 11:03:03
Mensagens: 78
Localização: Assis, São Paulo
Offline

Boa tarde Rafael,

de acordo com o retorno, o xml que contém elementos inválidos não é o consReciNFe e sim o enviNFe, verifique o seu xml de envio se há algum espaço nas chaves ou algum outro caracter inválido.


Att,
Vinicius
[MSN]
rafael.paz

JavaC Membro

Membro desde: 21/01/2013 10:53:57
Mensagens: 17
Offline

Boa tarde vinnykrs!

Cara, muito obrigado pela resposta! Na verdade até pensei nesta possibilidade, porém quando eu enviei o xml de lote eu recebi o xml abaixo, então pensei que tudo estivesse ok.

Valeu!



 
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Ir para:   
Powered by JForum 2.1.9 © JForum Team