Login Registre-se
Problema com cabeçalho de XML ao converter para OMElement com AXIOMUtil.stringToOM(xml)  XML
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Autor Mensagem
andredalcin

JavaC Membro

Membro desde: 20/04/2013 11:40:29
Mensagens: 10
Offline

Olá pessoal do fórum, antes de mais nada quero dizer que procurei durante varios dias uma solução e não encontrei por isso recorri ao forum para tentar um esclarecimento do meu problema que consiste na seguinte situação; tenho um metodo que gera os dados referentes a consulta de uma NF-e no webservice NfeConsulta2 que esta listado abaixo:



a saida do primeiro System.ou.println na linha 61 é:


e da segunda é:


e o resultado após a consulta no ws é:


ou seja, oque esta acontecendo é que quando o metodo OMElement element = AXIOMUtil.stringToOM(dadosMsg); e chamado ele remove a primeira linha do xml que estou gerando, e já procurei uma solução na internet durante varios dias, pesquisei li reli tópicos e documentações e nao entendi o que esta acontecendo! gostaria de saber se algum dos colegas podem me ajudar nisso??

ai tentei utlizar o codigo abaixo para substituir o metodo das linha 63 à 65:

porem o sistema gera um Exception ao chegar na linha NfeConsulta2Stub.NfeDadosMsg nfe = NfeConsulta2Stub.NfeDadosMsg.Factory.parse(reader); com a seguinte descrição:

java.lang.Exception: org.apache.axis2.databinding.ADBException: Unexpected subelement xServ
at br.inf.portalfiscal.www.nfe.wsdl.nfeconsulta2.NfeConsulta2Stub$NfeDadosMsg$Factory.parse(NfeConsulta2Stub.java:2294)
at br.com.ncmhelper.nfe.status.testes.Teste.main(Teste.java:70)
Caused by: org.apache.axis2.databinding.ADBException: Unexpected subelement xServ
at br.inf.portalfiscal.www.nfe.wsdl.nfeconsulta2.NfeConsulta2Stub$NfeDadosMsg$Factory.parse(NfeConsulta2Stub.java:228
... 1 more


novamente busquei na internet uma solução e infelizmente não encontrei!!!

Desde já agradeço a ajuda!!

Esta mensagem foi editada 1 vez. Última atualização foi em 02/05/2013 13:15:25


Att,
André Dalcin
Planos Assessoria & Planejamento Tributário
vinnykrs

JavaC Membro

Membro desde: 03/10/2012 11:03:03
Mensagens: 78
Localização: Assis, São Paulo
Offline

Cara, verifique aí a linha 55 e 71, vc está passando o valor "3.00" pra versão, quando na verdade deveria ser "2.01"
[MSN]
andredalcin

JavaC Membro

Membro desde: 20/04/2013 11:40:29
Mensagens: 10
Offline

vinnykrs wrote:Cara, verifique aí a linha 55 e 71, vc está passando o valor "3.00" pra versão, quando na verdade deveria ser "2.01"


Olá vinnykrs, muito obrigado pela ajuda mas infelizmente este não é o problema, ja efetuei inumeras vezes testes com as versões 2.00, 2.01 e 3.00 e não obtive sucesso!! somente a mesma mensagem de falha do esquema xml!!


como eu disse o problema ao que me parece estar na remoção da linha de declaração e de encoding da xml pelo stringToOM(), mas mesmo assim novamente muito obrigado pela força!!!

Esta mensagem foi editada 1 vez. Última atualização foi em 02/05/2013 13:14:59


Att,
André Dalcin
Planos Assessoria & Planejamento Tributário
andredalcin

JavaC Membro

Membro desde: 20/04/2013 11:40:29
Mensagens: 10
Offline

Up!!

Att,
André Dalcin
Planos Assessoria & Planejamento Tributário
andredalcin

JavaC Membro

Membro desde: 20/04/2013 11:40:29
Mensagens: 10
Offline

Up!!

Att,
André Dalcin
Planos Assessoria & Planejamento Tributário
andredalcin

JavaC Membro

Membro desde: 20/04/2013 11:40:29
Mensagens: 10
Offline

Up again!!

Att,
André Dalcin
Planos Assessoria & Planejamento Tributário
andredalcin

JavaC Membro

Membro desde: 20/04/2013 11:40:29
Mensagens: 10
Offline

Please!!! alguem pode me dar uma luz???

Att,
André Dalcin
Planos Assessoria & Planejamento Tributário
andredalcin

JavaC Membro

Membro desde: 20/04/2013 11:40:29
Mensagens: 10
Offline

Pessoal, eu sei que é meu primeiro post no forum!! mas eu descobri ele agora!! se alguem puder me ajudar eu com certeza irei contribuir para a comunidade com o que eu conheço em outras areas estou começando agora aqui, mas posso ajudar em alguma coisa!!, recorri a este forum por que foi o furom que mais encontrei material sobre a questão de comunicação com os WebServices do Governo!! mas pelo que vejo não devo ser merecedor de ajuda!!

Obrigado!!

Att,
André Dalcin
Planos Assessoria & Planejamento Tributário
eduuardobh

JavaC Membro

Membro desde: 05/09/2011 14:47:52
Mensagens: 27
Localização: Pelotas
Offline

Estou passando por um problema semelhante a este e percebi que ele só acontece na versão mais atualizada do Java, no caso a versão 7u25, tenta reverter a sua versão e ver se o problema pare de acontecer. Caso seja isto mesmo eu posso te informar caso encontre alguma solução.
Abraços
 
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Ir para:   
Powered by JForum 2.1.9 © JForum Team