Login Registre-se
Problema ao validar xml  XML
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Autor Mensagem
Luciano_Lopes

JavaC Membro

Membro desde: 29/11/2011 09:37:49
Mensagens: 63
Offline

Pessoal, quando tento validar o xml(schema fornecido aqui no forum) aparece o seguinte erro:

pedro.henrique

JavaC Membro

Membro desde: 19/11/2012 18:12:59
Mensagens: 36
Offline

Ola amigo posta o xml para poder analisar.
Luciano_Lopes

JavaC Membro

Membro desde: 29/11/2011 09:37:49
Mensagens: 63
Offline

Esse é o xml que tem aqui no forum

pedro.henrique

JavaC Membro

Membro desde: 19/11/2012 18:12:59
Mensagens: 36
Offline

O Arquivo XML não esta assinado.
Luciano_Lopes

JavaC Membro

Membro desde: 29/11/2011 09:37:49
Mensagens: 63
Offline

Eu achava que tinha que validar e depois assinar, acho que é por isso que ta dando errado, to fazendo ao contrario rsrs
pedro.henrique

JavaC Membro

Membro desde: 19/11/2012 18:12:59
Mensagens: 36
Offline

Tentar assinar e depois validar o arquivo xml.
jocabaldini

JavaC Membro

Membro desde: 31/10/2012 14:21:25
Mensagens: 178
Offline

Eu faço a validação 2x, primeiro na hora de gerar o XML e de novo depois de assinar.

Assim, na hora que vc está gerando o XML vc pode verificar se o XML está correto (apenas com o erro de falta de assinatura) e salvar no BD.

De qq forma o XML tem que ser validado após a assinatura.
Luciano_Lopes

JavaC Membro

Membro desde: 29/11/2011 09:37:49
Mensagens: 63
Offline

Valeu pela diva <b>jocabaldini</b>, farei isso
 
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Ir para:   
Powered by JForum 2.1.9 © JForum Team