Login Registre-se
Erro no tomcat ao usar jpa, jsf, mysql e eclipse  XML
Índice dos Fóruns » Desenvolvimento Web
Autor Mensagem
wendel.menegasso

JavaC Membro

Membro desde: 01/12/2012 17:02:46
Mensagens: 42
Offline


Esta mensagem foi editada 1 vez. Última atualização foi em 17/07/2013 10:24:05

jeroqueiroz

Moderador
[Avatar]

Membro desde: 11/06/2011 09:45:18
Mensagens: 1348
Localização: Bahia
Offline

Seja mais claro, pois este erro parece ser de configuração. Sempre uso aqui as ferramentas que se refere e funciona perfeitamente.

Explique quando e como ocorre o erro? As versões das ferramentas que esta usando? Como esta configurando?

Jeremias Santos
Seguir no Twitter @jeroqueiroz
Blog Jeroqueiroz


Projeto NF-e, CT-e, CC-e? Comece Por Aqui!


Membros do fórum,

Usem a tag [code] e [/code] quando postarem Códigos Java e ou exemplos de XMLs.
Evitem tópicos duplicados.
Tópico solucionado? Edite o primeiro post e coloque [RESOLVIDO] no final do título.
Evitem reviver tópicos antigos.

O tópico resolveu seu problema? Seja gentil, comente e ou agradeça quem contribuiu com a solução.

Obrigado!
[Email] [WWW] [Yahoo!] [MSN]
wendel.menegasso

JavaC Membro

Membro desde: 01/12/2012 17:02:46
Mensagens: 42
Offline



Esse é o arquivo web.xml

<?xml version="1.0" encoding="UTF-8"?>

<faces-config
xmlns="http://java.sun.com/xml/ns/javaee"
xmlnssi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-facesconfig_2_0.xsd"
version="2.0">

</faces-config>

Arquivo faces-config.xml


Fornecedor.xhtml


FornecedorBean.java


jpafilter.javaGeratabelas.java

Fornecedor.java

FornecedorRepository.java


persistence.xml

O programa basicamente é composto de uma tela que o usuário digita os dados(JSF) e os dados são inseridos no banco de dados(Hibernate)
Estou utilizando o eclipse indigo.
MySQL.
JSF 2.0.
jeroqueiroz

Moderador
[Avatar]

Membro desde: 11/06/2011 09:45:18
Mensagens: 1348
Localização: Bahia
Offline

Quais as libs contam no projeto? Você setou elas no Classpath?

A principio acho que o erro esta na questão de configurações.

Jeremias Santos
Seguir no Twitter @jeroqueiroz
Blog Jeroqueiroz


Projeto NF-e, CT-e, CC-e? Comece Por Aqui!


Membros do fórum,

Usem a tag [code] e [/code] quando postarem Códigos Java e ou exemplos de XMLs.
Evitem tópicos duplicados.
Tópico solucionado? Edite o primeiro post e coloque [RESOLVIDO] no final do título.
Evitem reviver tópicos antigos.

O tópico resolveu seu problema? Seja gentil, comente e ou agradeça quem contribuiu com a solução.

Obrigado!
[Email] [WWW] [Yahoo!] [MSN]
wendel.menegasso

JavaC Membro

Membro desde: 01/12/2012 17:02:46
Mensagens: 42
Offline

Como assim setando elas no classpath?
Você pode me explicar o que seria isso?
Eu adicionei todos os jars do hibernate ao projeto.
Eu adicionei o mojarra no jsf ao projeto.
Eu adicionei o conector de mysql(jar) ao projeto.
Eu add o jstl.jar ao projeto.
wendel.menegasso

JavaC Membro

Membro desde: 01/12/2012 17:02:46
Mensagens: 42
Offline

Consegui resolver esse problema. O problema estava em web.xml

Só que a aplicação ainda não funciona ele dá essa mensagem no browser:

type Status report

message /Hercules/faces/Fornecedor.xhtml

description The requested resource is not available.


jeroqueiroz

Moderador
[Avatar]

Membro desde: 11/06/2011 09:45:18
Mensagens: 1348
Localização: Bahia
Offline

Qual o problema no momento este ou o do outro tópico?

http://www.javac.com.br/jc/posts/list/0/1600.page#6603

Jeremias Santos
Seguir no Twitter @jeroqueiroz
Blog Jeroqueiroz


Projeto NF-e, CT-e, CC-e? Comece Por Aqui!


Membros do fórum,

Usem a tag [code] e [/code] quando postarem Códigos Java e ou exemplos de XMLs.
Evitem tópicos duplicados.
Tópico solucionado? Edite o primeiro post e coloque [RESOLVIDO] no final do título.
Evitem reviver tópicos antigos.

O tópico resolveu seu problema? Seja gentil, comente e ou agradeça quem contribuiu com a solução.

Obrigado!
[Email] [WWW] [Yahoo!] [MSN]
wendel.menegasso

JavaC Membro

Membro desde: 01/12/2012 17:02:46
Mensagens: 42
Offline

Na verdade os dois.
Ele ta dando o erro no log do tomcat, e quando vou rodar a aplicação dá essa mensagem.
Acredito que seja por causa do erro do outro tópico.
 
Índice dos Fóruns » Desenvolvimento Web
Ir para:   
Powered by JForum 2.1.9 © JForum Team