Login Registre-se
Erro ao criar enviNFe  XML
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Autor Mensagem
GGarcia

JavaC Membro
[Avatar]

Membro desde: 28/05/2013 17:12:21
Mensagens: 332
Offline

Boa tarde amigos da Comunidade JavaC

Estou com dificuldade em gerar o arquivo de envio de lote.

Eu gero o arquivo com a seguinte estrutura:



O problema que enfrento é o seguinte:

A estrutura acima é assinada sem problemas. Quando valido ela utilizando o XSD correspondente, ele me retorna que TODOS os elementos dentro da tag <NFe> estão incorretos e não deviam estar ali. Se ignorar os erros tentar enviar o lote, recebo o código de erro 225, erro de Schema do XML.

Pelo exemplo que vi aqui no fórum, tem uma parte que está diferente.

Quando eu abro a tag <NFe>, eu coloco o atributo

O exemplo de XML assinado, http://www.javac.com.br/downloads/XML/XML_Assinado-env-lot.xml não possui tal atributo na tag <NFe>, mas se eu suprimir esse atributo do meu código, a assinatura falha pois ele questiona a falta desse atributo na tag que precisa ser assinada.

Alguém saberia apontar o que estou fazendo de errado?

Obrigado pela ajuda.

If you're here, who's running hell?
GGarcia

JavaC Membro
[Avatar]

Membro desde: 28/05/2013 17:12:21
Mensagens: 332
Offline

Desculpem o incômodo, mas acabei descobrindo o problema.

Estava com alguns erros ao criar a estrutura do XML onde algumas tags estavam vazias e eram geradas de modo errado.

Abraço

If you're here, who's running hell?
 
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Ir para:   
Powered by JForum 2.1.9 © JForum Team