Login Registre-se
[RESOLVIDO] Unable to sendViaPost to url[https://homologacao.nfe.fazenda.sp.gov.br/...  XML
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Autor Mensagem
marcosfonceka

JavaC Membro

Membro desde: 30/03/2012 13:21:48
Mensagens: 118
Localização: Mineiros do Tietê/SP
Offline

Boa tarde.

Estou com esse erro estourando. Estranho que não é a todo instante.

Já troquei de certificado, usando 2 cartões de clientes diferentes. Tentei pelo A1 também, mas sem sucesso.
Lí aqui no próprio fórum que uns atualizaram o Java da máquina e geraram novamente os arquivos cacerts.
Fiz, então. Atualizei o Java e gerei de novo, mas sem sucesso.
Outro post dizia pra adicionar a linha:



no método que aciona o certificado ou no início da aplicação, mas sem sucesso.
Eu estou usando o certificado pelo repositório do sistema operacional.


Então a minha lógica é: salvar o nome do certificado numa coluna de uma determinada tabela e a partir disso montar o uso do certificado.

Abaixo eu colei a pilha de erro.

Até breve.

Esta mensagem foi editada 1 vez. Última atualização foi em 27/05/2014 10:48:42


--
Marcos Roberto da Fonseca
[Email] [MSN]
jeroqueiroz

Moderador
[Avatar]

Membro desde: 11/06/2011 09:45:18
Mensagens: 1348
Localização: Bahia
Offline

Geralmente problema com a instalação do certificado na maquina ou geração do Cacerts.

Se for A1 faz o processo de importação e depois exportação do certificado.

Jeremias Santos
Seguir no Twitter @jeroqueiroz
Blog Jeroqueiroz


Projeto NF-e, CT-e, CC-e? Comece Por Aqui!


Membros do fórum,

Usem a tag [code] e [/code] quando postarem Códigos Java e ou exemplos de XMLs.
Evitem tópicos duplicados.
Tópico solucionado? Edite o primeiro post e coloque [RESOLVIDO] no final do título.
Evitem reviver tópicos antigos.

O tópico resolveu seu problema? Seja gentil, comente e ou agradeça quem contribuiu com a solução.

Obrigado!
[Email] [WWW] [Yahoo!] [MSN]
marcosfonceka

JavaC Membro

Membro desde: 30/03/2012 13:21:48
Mensagens: 118
Localização: Mineiros do Tietê/SP
Offline

Estou usando o cartão - A3 da Caixa.

Como eu posso fazer pra tentar acertar isso?

Vou tentar remover o certificado e instalar de novo.

--
Marcos Roberto da Fonseca
[Email] [MSN]
jeroqueiroz

Moderador
[Avatar]

Membro desde: 11/06/2011 09:45:18
Mensagens: 1348
Localização: Bahia
Offline

Veja que geralmente possui uma cadeia de certificados disponível pelo fabricante, tente instalar esta cadeia de certificados. Após faça novamente a instalação do Certificado.

Após instalar faça um teste com o Emissor gratuito para verificar se o mesmo esta reconhecendo o certificado.

Jeremias Santos
Seguir no Twitter @jeroqueiroz
Blog Jeroqueiroz


Projeto NF-e, CT-e, CC-e? Comece Por Aqui!


Membros do fórum,

Usem a tag [code] e [/code] quando postarem Códigos Java e ou exemplos de XMLs.
Evitem tópicos duplicados.
Tópico solucionado? Edite o primeiro post e coloque [RESOLVIDO] no final do título.
Evitem reviver tópicos antigos.

O tópico resolveu seu problema? Seja gentil, comente e ou agradeça quem contribuiu com a solução.

Obrigado!
[Email] [WWW] [Yahoo!] [MSN]
marcosfonceka

JavaC Membro

Membro desde: 30/03/2012 13:21:48
Mensagens: 118
Localização: Mineiros do Tietê/SP
Offline

Desculpa a falta de experiência, é por isso que eu estou aqui, mas por onde eu começo?

Removo os certificados lá do "conteúdo do IE"?
Depois desinstalo o programa do leitor? E instalo de novo?

--
Marcos Roberto da Fonseca
[Email] [MSN]
jeroqueiroz

Moderador
[Avatar]

Membro desde: 11/06/2011 09:45:18
Mensagens: 1348
Localização: Bahia
Offline

Já fez o teste com o emissora gratuito para saber se ele esta instalado corretamente?

Jeremias Santos
Seguir no Twitter @jeroqueiroz
Blog Jeroqueiroz


Projeto NF-e, CT-e, CC-e? Comece Por Aqui!


Membros do fórum,

Usem a tag [code] e [/code] quando postarem Códigos Java e ou exemplos de XMLs.
Evitem tópicos duplicados.
Tópico solucionado? Edite o primeiro post e coloque [RESOLVIDO] no final do título.
Evitem reviver tópicos antigos.

O tópico resolveu seu problema? Seja gentil, comente e ou agradeça quem contribuiu com a solução.

Obrigado!
[Email] [WWW] [Yahoo!] [MSN]
marcosfonceka

JavaC Membro

Membro desde: 30/03/2012 13:21:48
Mensagens: 118
Localização: Mineiros do Tietê/SP
Offline

Boa noite.

Cara você tem ideia de como me ajudar?

--
Marcos Roberto da Fonseca
[Email] [MSN]
marcosfonceka

JavaC Membro

Membro desde: 30/03/2012 13:21:48
Mensagens: 118
Localização: Mineiros do Tietê/SP
Offline

Notei que ao tentar consumir de forma desenfreada os serviços, esse erro retornava até nos exemplos baixados aqui do Fórum, quando fui alertado sobre uma Nota Técnica que diz a respeito do consumo dos serviços disponibilizados.
Comecei a trabalhar em rotinas que ajudam a respeitar as regras de melhor consumo e o resultado tem sido agradável, pois a nota diz por exemplo, que o intervalo entre consultas (delay) de no mínimo 3 minutos para a consulta de status, então eu concluo que o erro pode ser uma negação de serviço.
Fiz o teste com a URL da consulta de status do ambiente de envio do estado do Rio Grande do Sul e não tive nenhum erro, sem mudar nada no código (a não ser a URL, e código do estado, claro).
Agradeço aos contribuintes do fórum pela ajudada oferecida.
Abraço!

--
Marcos Roberto da Fonseca
[Email] [MSN]
 
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Ir para:   
Powered by JForum 2.1.9 © JForum Team