Login Registre-se
org.apache.axis2.AxisFault: Received fatal alert: handshake_failure  XML
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Autor Mensagem
leandro.souzaprata

JavaC Membro
[Avatar]

Membro desde: 04/10/2013 10:35:41
Mensagens: 49
Offline

Boa tarde!
Estou com esse problema na hora de enviar e consultar o retorno do processamento da NFe... aparece a mensagem: org.apache.axis2.AxisFault: Received fatal alert: handshake_failure
O estranho que isso não acontece sempre... de cada dez notas que eu envio, umas duas acontece esse erro... e depois tento enviar a mesma nota que deu erro sem fazer nenhuma alteração e ela é recebida, processada e autorizada normalmente...

colequei esse código que encontrei aqui no forum..


mas continua a mesma coisa.... alguém ja passou por isso?
Zovao

JavaC Membro

Membro desde: 28/01/2012 11:50:16
Mensagens: 190
Offline

Olá Leandro,

Eu também tive esse mesmo problema.
Dava esse erro e do nada pára de dar. Mas comigo isso ocorre somente na versao 3.10. E só em homologação, pois ainda não coloquei em produção o 3.10.
No layout 2.0 nunca deu esse erro.
Também não sei o que é. Se descobrir por favor, avise-nos.

Abraços,
Zovao
vsmweb

JavaC Membro
[Avatar]

Membro desde: 14/01/2014 14:12:00
Mensagens: 37
Localização: Assis, SP
Offline

Olá pessoal,

Eu também estou enfrentando esse problema, e é o mesmo cenário, a cada 10 autorizações que faço, uma ou outra retorna esse erro, e na sequencia se tentar enviar o mesmo xml ele autoriza.
O mais estranho é que esse erro ocorre somente ao tentar consumir o SEFAZ de SP, quando disparo a requisição para MT ou PR vai normalmente.
Também já "setei" essa property "System.setProperty("sun.security.ssl.allowUnsafeRenegotiation", "true");" e continua o mesmo erro.

Li algumas coisas dizendo que esse erro ocorre devido a cadeia de certificação do Certificado Digital que esta usando estar desatualizada. (mas não entendi muito bem o porque, visto que só ocorre no SEFAZ no SP).

Quando ao que o "Zovao" citou sobre ser ambiente de homologação, confesso que não sei se isso será solucionado no ambiente de produção, pois estava efetuando alguns testes no SEFAZ do MT, e recebi vários erros mesmo no ambiente de produção como "999-Erro não catalogado".

Enfim... caso consigam solucionar, postem aqui para ajudar-nos !

Vlw ...

Esta mensagem foi editada 2 vezes. Última atualização foi em 02/07/2014 10:06:25


--
Grato.
Att...
VSM - Equipe WEB
http://www.vsm.com.br/
[WWW]
 
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Ir para:   
Powered by JForum 2.1.9 © JForum Team