Login Registre-se
Erro ao validar o XML do CT-e assinado.  XML
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Autor Mensagem
franzisk

JavaC Membro
[Avatar]

Membro desde: 29/05/2014 07:39:19
Mensagens: 128
Offline

Pessoal,

Quando eu valido o XML sem a assinatura ele acusa:
O conteúdo do elemento "CTe" não está completo. Um dos "http://www.w3.org/2000/09/xmldsig#:Signature" é esperado.

Em seguida pego o mesmo XML e faço a assinatura e mando novamente validar, aí ele acusa:
Encontrado o campo "Signature". Um dos "http://www.portalfiscal.inf.br/cte:CTe" é esperado.

O seja, o campo "Signature" tá ficando no lugar do CTe? Não entendi.

Segue o XML (assinado):


XML antes da assinatura:


Será que alguém poderia me dar uma dica do que estou fazendo errado?

#@%$"'/
franzisk

JavaC Membro
[Avatar]

Membro desde: 29/05/2014 07:39:19
Mensagens: 128
Offline

franzisk wrote:Pessoal,

Quando eu valido o XML sem a assinatura ele acusa:
O conteúdo do elemento "CTe" não está completo. Um dos "http://www.w3.org/2000/09/xmldsig#:Signature" é esperado.

Em seguida pego o mesmo XML e faço a assinatura e mando novamente validar, aí ele acusa:
Encontrado o campo "Signature". Um dos "http://www.portalfiscal.inf.br/cte:CTe" é esperado.

O seja, o campo "Signature" tá ficando no lugar do CTe? Não entendi.

Segue o XML (assinado):


XML antes da assinatura:


Será que alguém poderia me dar uma dica do que estou fazendo errado?

#@%$"'/
 
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Ir para:   
Powered by JForum 2.1.9 © JForum Team