Login Registre-se
[Resolvido] - eventoCTe - Cancelamento  XML
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Autor Mensagem
pimenta

JavaC Membro

Membro desde: 07/07/2014 10:24:55
Mensagens: 23
Localização: Rio Claro - SP
Offline

Boa tarde galera, estou tentando enviar o XML assinado para o cancelamento de homologação :



Está me retornando :



Alguém sabe o por que ? Está faltando alguma informação ?

Obrigado !!!

Esta mensagem foi editada 1 vez. Última atualização foi em 17/07/2014 09:21:42

[Email] [WWW] [MSN]
pimenta

JavaC Membro

Membro desde: 07/07/2014 10:24:55
Mensagens: 23
Localização: Rio Claro - SP
Offline

Bom dia galera, foi resolvido o problema, apenas estava enviando para o servidor errado !

Eu enviava para :
https://homologacao.nfe.fazenda.sp.gov.br/cteWEB/services/cteCancelamento.asmx

Porém o correto, como o cancelamento se tornou um evento, é para :
https://homologacao.nfe.fazenda.sp.gov.br/cteWEB/services/cteRecepcaoEvento.asmx

Obrigado a todos !

Esta mensagem foi editada 1 vez. Última atualização foi em 17/07/2014 09:21:00

[Email] [WWW] [MSN]
marcioandre

JavaC Membro

Membro desde: 14/04/2011 19:16:54
Mensagens: 77
Offline

Olá pimenta, tem como você compartilhar essa classe de cancelamento, pois não estou conseguindo gerar essa classe.
[MSN]
pimenta

JavaC Membro

Membro desde: 07/07/2014 10:24:55
Mensagens: 23
Localização: Rio Claro - SP
Offline

Tem sim, segue :
Aqui o método da chamada :

e onde monta o xml para cancelar :


Cancelando que tá uma beleza aqui ... rrsrsrsr
[Email] [WWW] [MSN]
marcioroloff

JavaC Membro

Membro desde: 11/12/2012 13:05:05
Mensagens: 16
Offline

Oi Pimenta, como está sua classe que comunica e envia o evento, estou gerando o xml certinho, porém não estou conseguindo enviar e pegar o retorno.
pimenta

JavaC Membro

Membro desde: 07/07/2014 10:24:55
Mensagens: 23
Localização: Rio Claro - SP
Offline

Segue a chamada :


Esta retornando algum erro ?
[Email] [WWW] [MSN]
marcioroloff

JavaC Membro

Membro desde: 11/12/2012 13:05:05
Mensagens: 16
Offline

Estou recebendo o seguinte erro:
marcioroloff

JavaC Membro

Membro desde: 11/12/2012 13:05:05
Mensagens: 16
Offline

Segue método que estou usando:
marcioroloff

JavaC Membro

Membro desde: 11/12/2012 13:05:05
Mensagens: 16
Offline

Problema resolvido, usei a biblioteca Stub do Pimenta, a qual foi gerada com uma versão Axis diferente da que eu tinha no meu projeto, atualizei o Axis no meu projeto e funcionou!!!
thiago oliveira

JavaC Membro

Membro desde: 28/02/2012 16:25:27
Mensagens: 69
Offline

Marcioroloff, estou com esse problema, como você resolveu?
se eu trocar a versão do AXIS, funciona porem outros metodos param de funcionar.
marcioroloff

JavaC Membro

Membro desde: 11/12/2012 13:05:05
Mensagens: 16
Offline

Oi Thiago.

Você removeu a versão anterior do AXIS, pode estar dando conflito.
thiago oliveira

JavaC Membro

Membro desde: 28/02/2012 16:25:27
Mensagens: 69
Offline

marcioroloff, eu tive que gerar os WSDL tudo com a versao do Axis 1.5.3,
do CTe para ficar tudo com a mesma versão, só assim funcionou perfeitamente.
Obrigado pela força.
 
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Ir para:   
Powered by JForum 2.1.9 © JForum Team