Login Registre-se
Erro ao transmitir NF-e após atualização java 8  XML
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Autor Mensagem
ivandm

JavaC Membro
[Avatar]

Membro desde: 05/02/2012 12:00:22
Mensagens: 92
Localização: Venâncio Aires
Offline

Pessoal, em um cliente após atualizar para Java 8, está me retornando o erro:

Rejeicao: Usar somente o namespace padrao da NF-e (Elemento: enviNFe)

Removi a atualização e funcionando ok.

Alguém tem idéia o que pode ser?

Não pesquisei nada, até por ser bem recente... talvez outros colegas terão mesmo problema.

Ivan Melchiors
Engenheiro da Computação - Univates
Intercompi Tecnologia da Informação
[WWW]
lucianohdr

JavaC Membro
[Avatar]

Membro desde: 26/12/2012 16:34:43
Mensagens: 42
Localização: Francisco Beltrão - Paraná
Offline

Olá,
em algum lugar do código e em algum lugar do xml, está sendo colocado um namespace que não o exigido pela receita

xmlns="http://www.portalfiscal.inf.br/nfe"

muito provavelmente no elemento enviNFe, é preciso dar uma olhada nos xml que estão sendo gerados, tanto numa versão quanto na outra do java

desculpe se estou sendo muito óbvio

lucianohdr é legal. Mas Luciano fica bem melhor
ivandm

JavaC Membro
[Avatar]

Membro desde: 05/02/2012 12:00:22
Mensagens: 92
Localização: Venâncio Aires
Offline

Fala colega, tudo certo, você leu ali, o problema aconteceu com a nova atualização do Java 8.

Voltei pro 7 e tudo ok.

Vou verificar sim se alguma função do Java 8 com String mudou...

Ivan Melchiors
Engenheiro da Computação - Univates
Intercompi Tecnologia da Informação
[WWW]
ivandm

JavaC Membro
[Avatar]

Membro desde: 05/02/2012 12:00:22
Mensagens: 92
Localização: Venâncio Aires
Offline

E o próprio emissor gratuito está com problemas utilizando o Java 8.

Só pra ressaltar, que realmente algo mudou no Java 8.

Ivan Melchiors
Engenheiro da Computação - Univates
Intercompi Tecnologia da Informação
[WWW]
andrejm

JavaC Membro

Membro desde: 26/07/2015 21:37:05
Mensagens: 39
Offline

olá também estou utilizando java 8 e ocorreu este problema.. alguma solução?
evandropasini

JavaC Membro

Membro desde: 04/11/2014 10:10:37
Mensagens: 19
Offline

Eu tive esse problema também, no meu caso eu reparei que usando o java 8 era criado o namespace com um " "(espaço) a mais no final, se não me engano. então eu só coloquei um replace depois de gerar o xml e funcionou.
 
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Ir para:   
Powered by JForum 2.1.9 © JForum Team