Login Registre-se
Problema assinatura de evento de cancelamento <cStat>298</cStat>  XML
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Autor Mensagem
alyssonsilva

JavaC Membro

Membro desde: 10/10/2014 16:25:37
Mensagens: 7
Offline

Olá pessoal estou com um problema aqui ao realizar a operação de cancelamento da NF-e eu gerei meu XML, assinei, validei no schema
e enviei para receita do Paraná e eu até realizei a validação do xml naquele site da sefaz e diz que é válido.
Alguém tem alguma idéia??

Obs. o erro vem no retorno da receita <cStat>298</cStat><xMotivo>Assinatura difere do padrão do Projeto</xMotivo>

XML


Método que cancela


Retorno

Esta mensagem foi editada 1 vez. Última atualização foi em 28/10/2014 09:55:51

tiagoberga

Moderador
[Avatar]

Membro desde: 11/03/2014 10:10:20
Mensagens: 447
Offline

Verifique o seu xml de entrada, QUASE 100% DE CHANCE DELE ESTAR ERRADO, o que está causando este seu problema....

Esta mensagem foi editada 1 vez. Última atualização foi em 28/10/2014 13:26:25


Tiago Bergamasco, 25 anos

Computer Scientist pela Centro Universitário Anhanguera
MBA Service-Oriented Architeture (SOA) pela Metrocamp - Ibmec
AngularJS Developer pela Caelum Ensino e Inovação- SP

Ao entrar em contato, por favor identifique-se antes
Site: Arara Tecnologia da Informação



Comercial: 19 996050532

"Uma imagem vale mil palavras. Uma interface vale mil imagens." - Ben Shneiderman
[Email] [WWW]
alyssonsilva

JavaC Membro

Membro desde: 10/10/2014 16:25:37
Mensagens: 7
Offline

Então Tiago eu até validei o xml na sefaz e aparece assinatura digital válida!!!

esse problema me parece acontecer no paraná!!!
alyssonsilva

JavaC Membro

Membro desde: 10/10/2014 16:25:37
Mensagens: 7
Offline

Alguém mais tem alguma idéia que possa contribuir comigo? agradeço desde já galera
evandropasini

JavaC Membro

Membro desde: 04/11/2014 10:10:37
Mensagens: 19
Offline

Olá alyssonsilva, não sei se já resolveu esse problema, mas pra mim estava acontecendo isso também e depois de várias tentativas e pesquisa descobri que o problema era a falta do "xmlns" na tag "evento".

Na hora de criar o OMElement ele perde o xmlns da tag então usei o código abaixo e resolveu o problema (retirado de http://www.javac.com.br/jc/posts/list/15-nfe-envio-do-lote-webservice-20.page)

alyssonsilva

JavaC Membro

Membro desde: 10/10/2014 16:25:37
Mensagens: 7
Offline

Realmente eu encontrei o problema aqui e era exatamente isso !!
mas valeu pela ajuda!
 
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Ir para:   
Powered by JForum 2.1.9 © JForum Team