Login Registre-se
XML de Envio para ConsultarNfseEnvio  XML
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Autor Mensagem
rapharezzi

JavaC Membro

Membro desde: 12/11/2014 10:26:39
Mensagens: 6
Offline

Olá.
Estou implementando a NFS-e para WebISS.
Estou tentando enviar o seguinte xml:

E também dessa forma, utilizando somente o objeto (ConsultarNfseEnvio) da classe gerado pelo XSD.

Mas estou tendo o seguinte erro:

Método de envio:

Alguém sabe como resolver ou sabe dizer se o xml está correto?
Desde já, agradeço.

tiagoberga

Moderador
[Avatar]

Membro desde: 11/03/2014 10:10:20
Mensagens: 449
Offline

Da uma procurada ali em cima na opção de busca do fórum sobre a exception org.apache.axis2.AxisFault,
alguns outros tópicos já trataram à respeito desse assunto e tenho certeza que irá encontrar a solução apropriada
para seu caso,

volte a postar caso seja necessário

Att

Esta mensagem foi editada 4 vezes. Última atualização foi em 12/11/2014 12:23:16


Tiago Bergamasco, 25 anos

Computer Scientist pela Centro Universitário Anhanguera
MBA Service-Oriented Architeture (SOA) pela Metrocamp - Ibmec
AngularJS Developer pela Caelum Ensino e Inovação- SP

Ao entrar em contato, por favor identifique-se antes
Site: Arara Tecnologia da Informação



Comercial: 19 996050532

"Uma imagem vale mil palavras. Uma interface vale mil imagens." - Ben Shneiderman
[Email] [WWW]
rapharezzi

JavaC Membro

Membro desde: 12/11/2014 10:26:39
Mensagens: 6
Offline

Valeu a dica tiagoberga, mas não consegui encontrar nada que me ajudasse.
Acredito que é meu xml de envio que esta errado.
O problema é que fiz vários exemplos de teste e nenhum sai do erro mencionado. E quando uso o SoapUI o xml de retorno é esse:

Também alterei a forma de consumir o webservice, até porque havia gerado as classes com um wsdl incompleto.
O código ficou assim:

Mas o retorno ainda continua sendo o mesmo.

E tentei o seguinte XML:

E também continua mesmo retorno, tanto para a aplicação quanto para o SoapUI.
Problema é que não tenho nenhum exemplo para o município (Sinop/MT) que estou implementando e o manual oferecido (WebISS) é bem fraquinho, só teoria e nenhum exemplo de implementação ou XML.

Mas, de qualquer forma obrigado.
tiagoberga

Moderador
[Avatar]

Membro desde: 11/03/2014 10:10:20
Mensagens: 449
Offline

rapharezzi, pelo conteúdo que voce tem informado me parece algo relacionado à NFe de Serviço certo? Eu conhecço muito pouco do assunto,
mas vou dar uma pesquisada mais a fundo para ver o que consigo, e mesmo que, caso consiga resolver, vou colocar o material
encontrado aqui, para talvez ajudá-lo;


Tiago Bergamasco, 25 anos

Computer Scientist pela Centro Universitário Anhanguera
MBA Service-Oriented Architeture (SOA) pela Metrocamp - Ibmec
AngularJS Developer pela Caelum Ensino e Inovação- SP

Ao entrar em contato, por favor identifique-se antes
Site: Arara Tecnologia da Informação



Comercial: 19 996050532

"Uma imagem vale mil palavras. Uma interface vale mil imagens." - Ben Shneiderman
[Email] [WWW]
rapharezzi

JavaC Membro

Membro desde: 12/11/2014 10:26:39
Mensagens: 6
Offline

Eae tiagoberga.
Consegui resolver!
Mas acredito que o problema era do lado do webservice.
Numa sexta ele retornava o erro acima e na segunda feira começou a retornar resposta do webservice.
Pra conseguir isso, simplesmente utilizei as classes geradas pelo schema. Populei os objetos e boa.

Só que agora não estou conseguindo assinar corretamente o xml.
Também estou utilizando as classes gerados pelo schema, mas não sei os valores corretos que devem ser passados.
Vou criar um tópico pra ver se alguém tem a resposta ou já passou por isso.
Abraços
cgraf

JavaC Membro

Membro desde: 13/08/2015 11:44:17
Mensagens: 1
Offline

Olá rapharezzi,

também estou tentando integrar com a WEBISS, mas de Guanambi/BA e não consigo gerar os stubs do Axis2. Eu salvo o wsdl em arquivo mas o eclipse indica erro de formato inválido.

Como você gerou os stubs? Você tem o arquivo wsdl para comparar com o meu?

Qualquer ajuda é bem vinda....

Consegui integrar com outros provedores sem problema, mas este tá dificil.

Obrigado!
rapharezzi

JavaC Membro

Membro desde: 12/11/2014 10:26:39
Mensagens: 6
Offline

Olá, cgraf...

Consegui gerar os arquivos seguindo esse link. http://felipenasc.blogspot.com.br/2013/12/acessando-o-web-service-de-nota-fiscal.html.
Acho que pra gerar já ajuda.

Quanto aos WSDL, um dos que usei segue abaixo:

RecepcionarLoteRps

Tenta gerar com esse. Se conseguir com esse exemplo, pode ser que seu arquivo WSDL esteja com algum problema.
 
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Ir para:   
Powered by JForum 2.1.9 © JForum Team