Login Registre-se
Problema em A3 ao transmitir, do nada começou, o que será?  XML
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Autor Mensagem
franzisk

JavaC Membro
[Avatar]

Membro desde: 29/05/2014 07:39:19
Mensagens: 128
Offline

Pessoal,

Hoje um cliente começou a ter esse problema e não temos ideia do que pode estar ocorrendo, sendo que até ontem fazia a transmissão sem problema alguma e nada, absolutamente nada, foi alterado no sistema.

É um A3 que transmite usando um Applet, seria algo relacionado ao CaCerts? Mas como pode ser se não foi alterado o applet? E o CaCerts está dentro do applet.

Já mandei verificar a validade e disseram que está OK.

Não sabemos o que fazer:



Se alguém souber de algo pra ajudar agradeço.

#@%$"'/
macielgoncalves

Administrador
[Avatar]

Membro desde: 06/03/2011 14:49:25
Mensagens: 1234
Localização: Tubarão - SC
Offline

Olá franzisk,

Provavelmente a SEFAZ alterou o certificado do Webservices, atualize seu arquivo Cacerts.

Abraços...

Maciel Gonçalves
Administrador (JavaC - Java Community)
Seguir no Twitter @macielgoncalves



Projeto NF-e, CT-e, CC-e? Comece Por Aqui!

Quer saber mais sobre NF-e? Acesse www.MACIELGONCALVES.com.br

"A mente que se abre a uma nova ideia jamais voltará ao seu tamanho original." Albert Einstein
"Seja liberal naquilo que você aceita, e conservador naquilo que você propaga". Jon Postel.
"A coisa mais indispensável a um homem é reconhecer o uso que deve fazer do seu próprio conhecimento". Platão


Emissão de Documentos Fiscais para Desenvolvedores Java


Membros do fórum,

Usem a tag [code] e [/code] quando postarem Códigos Java e ou exemplos de XMLs.
Evitem tópicos duplicados.
Tópico solucionado? Edite o primeiro post e coloque [RESOLVIDO] no final do título.
Evitem reviver tópicos antigos.

O tópico resolveu seu problema? Seja gentil, comente e ou agradeça quem contribuiu com a solução.

Obrigado!

[WWW] [MSN]
franzisk

JavaC Membro
[Avatar]

Membro desde: 29/05/2014 07:39:19
Mensagens: 128
Offline

Ah Maciel,

Esqueci de dizer, o cliente tem um A1 que está fazendo a transmissão sem nenhum problema, e ele usa o mesmo CaCert usado no Applet, com isso acho que o problema não é o cacert dos webservices. O que acha?

#@%$"'/
immouawad

JavaC Membro

Membro desde: 09/01/2013 21:53:50
Mensagens: 16
Offline

Estou tento o mesmo problema, atualizei os Cacerts e o erro persiste ...
franzisk

JavaC Membro
[Avatar]

Membro desde: 29/05/2014 07:39:19
Mensagens: 128
Offline

Amigo,

No seu caso é CT-e usando A3 com applet?

#@%$"'/
immouawad

JavaC Membro

Membro desde: 09/01/2013 21:53:50
Mensagens: 16
Offline

CTe usando standalone(Aplicativo Desktop) com A3 ...

Estou fazendo mais uma tentativa aqui vai demorar um pouco, pois estou gerando tudo novamente carecas xml etc.....

E se tiver sucesso te aviso, por favor se tiver alguma resposta me avise tambem.

Atenciosamente
Igor Mouawad
franzisk

JavaC Membro
[Avatar]

Membro desde: 29/05/2014 07:39:19
Mensagens: 128
Offline

Ok, pode deixar que te aviso.

Refizemos os Cacerts, com URL de Homo e Prod, vamos tentar novamente.

#@%$"'/
franzisk

JavaC Membro
[Avatar]

Membro desde: 29/05/2014 07:39:19
Mensagens: 128
Offline

Amigo,

Aqui em HOMOLOGAÇÃO deu certo a transmissão, isso depois de gerar novamente os CAcerts, fiz dois, um para cada ambiente.

Fazendo o envio e Homo usando o CAcert de Prod também deu certo.

Seguem arquivos anexos.

 Nome do arquivo CTeCacerts-homo.jks [Disk] Download
 Descrição
 Tamanho 96 Kbytes
 Baixado:  141 vez(es)

 Nome do arquivo CTeCacerts-prod.jks [Disk] Download
 Descrição
 Tamanho 96 Kbytes
 Baixado:  144 vez(es)


#@%$"'/
immouawad

JavaC Membro

Membro desde: 09/01/2013 21:53:50
Mensagens: 16
Offline

Ótimo, funcinou, eu ja tinha testado isso gerado cacerts novos mas eu cometi outro erro aqui. Agora tudo resolvido.

O problema era realmente gerar Cacerts novos.

Obrigado,

Atenciosamente
Igor Mouawad

franzisk wrote:Amigo,

Aqui em HOMOLOGAÇÃO deu certo a transmissão, isso depois de gerar novamente os CAcerts, fiz dois, um para cada ambiente.

Fazendo o envio e Homo usando o CAcert de Prod também deu certo.

Seguem arquivos anexos.

 
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Ir para:   
Powered by JForum 2.1.9 © JForum Team