Login Registre-se
Inutilização versão 3.10 com erro 239 - Versao do arquivo XML nao suportada [RESOLVIDO]  XML
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Autor Mensagem
cado_arena

JavaC Membro

Membro desde: 06/08/2013 15:11:59
Mensagens: 31
Offline

Bom dia a todos,

Estou tendo problema para homologar inutilização de NFe na versão 3.10. Minhas tentativas foram para os webservices do SVRS(https://nfe.svrs.rs.gov.br/ws/nfeinutilizacao/nfeinutilizacao2.asmx e https://homologacao.nfe.sefazvirtual.rs.gov.br/ws/nfeinutilizacao/nfeinutilizacao2.asmx) nos ambientes de produção e homologação, e São Paulo no ambiente de homologação(https://homologacao.nfe.fazenda.sp.gov.br/nfeweb/services/NfeInutilizacao2.asmx). No caso de SVRS sempre recebo o retorno "239 - Rejeicao: Versao do arquivo XML nao suportada" e para SP "239 - Rejeicao: Cabecalho - Versao do arquivo XML nao suportada". Apesar de validar no validador da SEFAZ de RS (https://www.sefaz.rs.gov.br/nfe/nfe-val.aspx) e pelo schema "inutNFe_v3.10.xsd" recebo as mensagem citadas acima. Alguém poderia indicar o erro que estou cometendo?

Segue XML:



XML de retorno:



Desde já agradeço a atenção.

Esta mensagem foi editada 1 vez. Última atualização foi em 30/07/2015 18:18:37

rfumiot

JavaC Membro
[Avatar]

Membro desde: 23/06/2015 17:19:55
Mensagens: 217
Offline

Esse xml você pegou dentro do ws? pois eu estava tendo um problema que eu gerava o cabeçalho com a versão correta mais era enviado outra versão;
cado_arena

JavaC Membro

Membro desde: 06/08/2013 15:11:59
Mensagens: 31
Offline

Bom dia rfumiot,

Agradeço a sua resposta, apesar do XML estar correto o problema era o cabeçalho da conexão mesmo. Ao criar a conexão com o webservice estava informando a versão 1.00 em vez da 3.10. Exemplo:


Agradeço a atenção.
 
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Ir para:   
Powered by JForum 2.1.9 © JForum Team