Login Registre-se
oberthur certificado erro webservice[RESOLVIDO]  XML
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Autor Mensagem
airtonct

JavaC Membro

Membro desde: 09/06/2016 22:17:10
Mensagens: 43
Offline

Estou tendo o mesmo erro descrito neste topico : http://www.javac.com.br/jc/posts/list/2516-erro-comunicacao-webservice-certificado-oberthur-technologies.page
adicionei estas linhas onde meu certificado é carregado


ficando assim:



Tenho clientes q começaram a usar este certificado e nao consigo achar uma solução
Alguem poderia me dar um norte?

Esta mensagem foi editada 1 vez. Última atualização foi em 19/12/2016 10:43:06

macega

JavaC Membro

Membro desde: 08/07/2015 10:17:16
Mensagens: 48
Offline

como vc esta usando



o SocketFactoryDinamico

provavelmente o problema pode ser nele, (mas estou dando um puta chute)
da uma olhada como está esse metodo




verifica esse linha





isso vc pode remover nao vai adiantar nada





Esta mensagem foi editada 2 vezes. Última atualização foi em 15/12/2016 18:49:41

airtonct

JavaC Membro

Membro desde: 09/06/2016 22:17:10
Mensagens: 43
Offline

Eu nao possuo estas linhas no meu socket

macega

JavaC Membro

Membro desde: 08/07/2015 10:17:16
Mensagens: 48
Offline

esse e o que eu estou usando, tenta fazer um teste com ela



eu achamo ela assim



no momento de enviar

Esta mensagem foi editada 2 vezes. Última atualização foi em 16/12/2016 13:55:02

airtonct

JavaC Membro

Membro desde: 09/06/2016 22:17:10
Mensagens: 43
Offline

Gostaria de agradecer pelas respostas, porem meu cliente só ira me devolver o certificado para novos testes segunda feira dia 19/12 então assim q possível irei postar aqui se as respostas resolveram meu problema.
airtonct

JavaC Membro

Membro desde: 09/06/2016 22:17:10
Mensagens: 43
Offline

Gostaria de agradecer ao macega que solucionou meu problema na mosca......
a solução postada por ele servirá para resolver os problemas do certificado Certisgn Oberthur
mto obg.
rlira

JavaC Membro

Membro desde: 07/01/2015 15:45:55
Mensagens: 59
Localização: Olinda - PE
Offline

Olá Boa tarde.

Estou com problemas com o certificado da Oberthur, estou tentando acessa-lo de forma direta mais não estou conseguindo, inclusive tentei fazer com o Emissor Gratuito da Sefaz e também deu erro sera que alguém poderia me dar uma ajuda

no momento eu estou tentando ler os dados do certificado e não consigo sair disto, li outros tópicos aqui no fórum, abri um tópico sobre este assunto mais minhas tentativas estão sendo em vão

http://www.javac.com.br/jc/posts/list/3242-certificado-a3-oberthur-java-exception.page

Robson Lira
Skype: robson.lira
macega

JavaC Membro

Membro desde: 08/07/2015 10:17:16
Mensagens: 48
Offline

já tentou em outra maquina, e acessar diretamente não e uma boa ideia
rlira

JavaC Membro

Membro desde: 07/01/2015 15:45:55
Mensagens: 59
Localização: Olinda - PE
Offline

Olá Macega boa tarde.


Primeiro Obrigado pelo retorno. e então deixa te dizer eu não tentei em outra maquina, alias eu tava remoto este tempo todo liguei agora pra o cara fim de semana posso pegar o hard e testar aqui
em casa. ele tem um notebook W10 64 bits versão Home, mais bem vale tentar.

agora sobre conectar direto vc quer dizer mudar o programa para acessar via repositório do Windows? isto eu não tentei na verdade pra isto terei que mudar aqui o programa


Robson Lira
Skype: robson.lira
rlira

JavaC Membro

Membro desde: 07/01/2015 15:45:55
Mensagens: 59
Localização: Olinda - PE
Offline

Olá Macega

Cara pensando bem nem é maquina porque, pelo Motivo de que pelo Emissor Gratuito
Usando o repositorio do Windows
- Foi emitido duas notas (NF-e)

Alterando o Emissor Gratuito para conectar direto também da erro assim como no programa que eu utilizo então nem é o caso de testar em outra maquina
o lance é Mudar o programa para pegar do repositorio do Windows

Robson Lira
Skype: robson.lira
macega

JavaC Membro

Membro desde: 08/07/2015 10:17:16
Mensagens: 48
Offline

so falei para testar em outra maquina porque no post anterior dizia que deu erro no emissor gratuito, mas ok

voce chegou a tentar usar esse ultimo codigo que tinha postado ??


rlira

JavaC Membro

Membro desde: 07/01/2015 15:45:55
Mensagens: 59
Localização: Olinda - PE
Offline

Prezados boa tarde

Consegui resolver o meu problema, era o arquivo .cfg eu não estava mudando o conteúdo de "name" foi só mudar e ficou assim e ta funfando legal agora

name=Oberthur
library=c:/windows/system32/OcsCryptoki.dll
showInfo=true

Robson Lira
Skype: robson.lira
 
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Ir para:   
Powered by JForum 2.1.9 © JForum Team