Login Registre-se
EFD-REINF  XML
Índice dos Fóruns » SPED / PAF-ECF / ESOCIAL / EFD_REINF
Autor Mensagem
joaorueda

JavaC Membro

Membro desde: 03/07/2017 11:52:00
Mensagens: 28
Offline

boa tarde Pessoas,

estou tentando fazer o envio do R1000 pro webservice do reinf

estou com o seguinte problema.. apos mandar o arquivo ele dá a mensagem quando era para dar o retorno...




alguem sabe me dizer o que pode ser isso ?

grato,
João Rueda

Esta mensagem foi editada 2 vezes. Última atualização foi em 04/09/2017 14:40:46

joaorueda

JavaC Membro

Membro desde: 03/07/2017 11:52:00
Mensagens: 28
Offline

Gerei novamente o stub com esse endereço

https://preprodefdreinf.receita.fazenda.gov.br/RecepcaoLoteReinf.svc?singleWSDL

Dai funfo !

Esta mensagem foi editada 1 vez. Última atualização foi em 04/09/2017 14:40:33

rootrey

JavaC Membro

Membro desde: 29/06/2017 22:13:45
Mensagens: 10
Offline

joaorueda wrote:
Gerei novamente o stub com esse endereço

https://preprodefdreinf.receita.fazenda.gov.br/RecepcaoLoteReinf.svc?singleWSDL

Dai funfo !



Boa tarde,

Como você esta preenchendo o "id" do lote de eventos ? não achei documentação de como preencher este campo.
joaorueda

JavaC Membro

Membro desde: 03/07/2017 11:52:00
Mensagens: 28
Offline

rootrey,

A identificação única do evento (Id) é composta por 36 caracteres, conforme o que segue: IDTNNNNNNNNNNNNNNAAAAMMDDHHMMSSQQQQQ ID - Texto Fixo "ID"; T - Tipo de Inscrição do Empregador (1 - CNPJ; 2 - CPF); NNNNNNNNNNNNNN - Número do CNPJ ou CPF do empregador - Completar com zeros à direita. No caso de pessoas jurídicas, o CNPJ informado deve conter 8 ou 14 posições de acordo com o enquadramento do contribuinte para preenchimento do campo {ideEmpregador/nrInsc} do evento R-1000, completando-se com zeros à direita, se necessário. AAAAMMDD - Ano, mês e dia da geração do evento; HHMMSS - Hora, minuto e segundo da geração do evento; QQQQQ - Número sequencial da chave. Incrementar somente quando ocorrer geração de eventos na mesma data/hora, completando com zeros à esquerda. OBS.: No caso de pessoas jurídicas, o CNPJ informado deverá conter 8 ou 14 posições de acordo com o enquadramento do contribuinte para preenchimento do campo {ideEmpregador/nrInsc} do evento S-1000, completando-se com zeros à direita, se necessário.

do layoute Leiautes da EFD-Reinf v1.1 - Anexo II - Regras de Validação.pdf
em http://sped.rfb.gov.br/projeto/show/1196

abraço,
João Rueda

Esta mensagem foi editada 1 vez. Última atualização foi em 04/09/2017 14:41:07

joaorueda

JavaC Membro

Membro desde: 03/07/2017 11:52:00
Mensagens: 28
Offline

Pessoal, desculpa mas vou reabrir ...

o wsdl do REINF não importa corretamente ou não está funcionando não sei dizer.

Se alguém mais tiver esse problema e puder informar como corrigir agradeço muito.

gerei o client do webservice pelo eclipse com axis2 utilizando o arquivo
http://sped.rfb.gov.br/arquivo/download/2307

ele não obtem a resposta e fica dando diversos erros tipo a primeira postagem ,,,

daí gerei novamente pelo endereço "https://preprodefdreinf.receita.fazenda.gov.br/RecepcaoLoteReinf.svc"

achei que tinha resolvido , pois começou a pegar a resposta depois de enviar o arquivo...

agora só retorna ...
<codigo>MS0092</codigo>
<descricao>Versão do lote inválida. Deve ser utilizada a versão 1.01.01.</descricao>

pela mensagem seria meio obvio, o cara tá usando a versão antiga dos eventos,

dai eu fui lá apaguei todos os XSD, baixei , conferi a versão 1.01.01, gerei as classes novamente e reenviei ...

continua dando o erro de versão de lote...

joaorueda

JavaC Membro

Membro desde: 03/07/2017 11:52:00
Mensagens: 28
Offline

rootrey

JavaC Membro

Membro desde: 29/06/2017 22:13:45
Mensagens: 10
Offline

joaorueda wrote:Pessoal, desculpa mas vou reabrir ...

o wsdl do REINF não importa corretamente ou não está funcionando não sei dizer.

Se alguém mais tiver esse problema e puder informar como corrigir agradeço muito.

gerei o client do webservice pelo eclipse com axis2 utilizando o arquivo
http://sped.rfb.gov.br/arquivo/download/2307

ele não obtem a resposta e fica dando diversos erros tipo a primeira postagem ,,,

daí gerei novamente pelo endereço "https://preprodefdreinf.receita.fazenda.gov.br/RecepcaoLoteReinf.svc"

achei que tinha resolvido , pois começou a pegar a resposta depois de enviar o arquivo...

agora só retorna ...
<codigo>MS0092</codigo>
<descricao>Versão do lote inválida. Deve ser utilizada a versão 1.01.01.</descricao>

pela mensagem seria meio obvio, o cara tá usando a versão antiga dos eventos,

dai eu fui lá apaguei todos os XSD, baixei , conferi a versão 1.01.01, gerei as classes novamente e reenviei ...

continua dando o erro de versão de lote...




Estou recebendo somente o retorno abaixo e não sei a causa do problema, pois passo meu lote no "envioLoteEventos-v1_01_01.xsd" e não tenho erros.
<codigo>MS0028</codigo><descricao>Lote inválido.</descricao>

joaorueda

JavaC Membro

Membro desde: 03/07/2017 11:52:00
Mensagens: 28
Offline

rootrey wrote:
joaorueda wrote:Pessoal, desculpa mas vou reabrir ...

o wsdl do REINF não importa corretamente ou não está funcionando não sei dizer.

Se alguém mais tiver esse problema e puder informar como corrigir agradeço muito.

gerei o client do webservice pelo eclipse com axis2 utilizando o arquivo
http://sped.rfb.gov.br/arquivo/download/2307

ele não obtem a resposta e fica dando diversos erros tipo a primeira postagem ,,,

daí gerei novamente pelo endereço "https://preprodefdreinf.receita.fazenda.gov.br/RecepcaoLoteReinf.svc"

achei que tinha resolvido , pois começou a pegar a resposta depois de enviar o arquivo...

agora só retorna ...
<codigo>MS0092</codigo>
<descricao>Versão do lote inválida. Deve ser utilizada a versão 1.01.01.</descricao>

pela mensagem seria meio obvio, o cara tá usando a versão antiga dos eventos,

dai eu fui lá apaguei todos os XSD, baixei , conferi a versão 1.01.01, gerei as classes novamente e reenviei ...

continua dando o erro de versão de lote...




Estou recebendo somente o retorno abaixo e não sei a causa do problema, pois passo meu lote no "envioLoteEventos-v1_01_01.xsd" e não tenho erros.
<codigo>MS0028</codigo><descricao>Lote inválido.</descricao>



poe seu xml ai pra gente ver
rootrey

JavaC Membro

Membro desde: 29/06/2017 22:13:45
Mensagens: 10
Offline

joaorueda wrote:
rootrey wrote:
joaorueda wrote:Pessoal, desculpa mas vou reabrir ...

o wsdl do REINF não importa corretamente ou não está funcionando não sei dizer.

Se alguém mais tiver esse problema e puder informar como corrigir agradeço muito.

gerei o client do webservice pelo eclipse com axis2 utilizando o arquivo
http://sped.rfb.gov.br/arquivo/download/2307

ele não obtem a resposta e fica dando diversos erros tipo a primeira postagem ,,,

daí gerei novamente pelo endereço "https://preprodefdreinf.receita.fazenda.gov.br/RecepcaoLoteReinf.svc"

achei que tinha resolvido , pois começou a pegar a resposta depois de enviar o arquivo...

agora só retorna ...
<codigo>MS0092</codigo>
<descricao>Versão do lote inválida. Deve ser utilizada a versão 1.01.01.</descricao>

pela mensagem seria meio obvio, o cara tá usando a versão antiga dos eventos,

dai eu fui lá apaguei todos os XSD, baixei , conferi a versão 1.01.01, gerei as classes novamente e reenviei ...

continua dando o erro de versão de lote...




Estou recebendo somente o retorno abaixo e não sei a causa do problema, pois passo meu lote no "envioLoteEventos-v1_01_01.xsd" e não tenho erros.
<codigo>MS0028</codigo><descricao>Lote inválido.</descricao>



poe seu xml ai pra gente ver



Segue:
joaorueda

JavaC Membro

Membro desde: 03/07/2017 11:52:00
Mensagens: 28
Offline

rootrey ,

vc acertou a montagem do ID ?

no manual está assim a parte da assinatura...



o seu está assinando com sha1

não é sha1 é sha256, mas se vc está acessando quer dizer que o webservice deles já não está fazendo a validação que eles falam de entrada , senão não ia voltar o erro
MS00XXX já ia dar um erro falando que o certificado tá invalido.

Antes de acertar a assinatura,

tenta tirar isso
do seu evento e enviar pra ver que mensagem dá ...
rootrey

JavaC Membro

Membro desde: 29/06/2017 22:13:45
Mensagens: 10
Offline

joaorueda wrote:rootrey ,

vc acertou a montagem do ID ?

no manual está assim a parte da assinatura...



o seu está assinando com sha1

não é sha1 é sha256, mas se vc está acessando quer dizer que o webservice deles já não está fazendo a validação que eles falam de entrada , senão não ia voltar o erro
MS00XXX já ia dar um erro falando que o certificado tá invalido.

Antes de acertar a assinatura,

tenta tirar isso
do seu evento e enviar pra ver que mensagem dá ...


Mesmo erro:
joaorueda

JavaC Membro

Membro desde: 03/07/2017 11:52:00
Mensagens: 28
Offline

Tenta alterar o envelope

assim :



vou tentar perguntar pro Pedro no forum do sped , ele tinha dito que conseguiu enviar o reinf e pegar o protocolo

talvez tenha que alterar a assinatura mesmo para sha256, só estou em dúvida quanto ao URI na assinatura.

rootrey

JavaC Membro

Membro desde: 29/06/2017 22:13:45
Mensagens: 10
Offline

joaorueda wrote:Tenta alterar o envelope

assim :



vou tentar perguntar pro Pedro no forum do sped , ele tinha dito que conseguiu enviar o reinf e pegar o protocolo

talvez tenha que alterar a assinatura mesmo para sha256, só estou em dúvida quanto ao URI na assinatura.



Fiz alguns ajustes e agora estou recebendo o mesmo erro que o seu

joaorueda

JavaC Membro

Membro desde: 03/07/2017 11:52:00
Mensagens: 28
Offline

acertou para sha256 ?

com o URI passando o ID ?

eu estou vendo aqui que o xsd do evtInfoContribuinte está diferendo do manual ...

você gera o xml do evento como ? JAXB ?
joaorueda

JavaC Membro

Membro desde: 03/07/2017 11:52:00
Mensagens: 28
Offline

ve o link que o pedro postou ...

https://ibb.co/kuK5Ek

não tem o envelope ! eu passei sem e o erro mudou ... agora está reclamando da assinatura

 
Índice dos Fóruns » SPED / PAF-ECF / ESOCIAL / EFD_REINF
Ir para:   
Powered by JForum 2.1.9 © JForum Team