Login Registre-se
Inutilização NFe V 4.00 - SAAJ0008: Bad Response; Bad Request [Resolvido]  XML
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Autor Mensagem
gilvangobbato

JavaC Membro

Membro desde: 16/07/2014 10:15:52
Mensagens: 21
Offline

Ola pessoal,

Não estou conseguindo realizar a inutilização de documentos fiscais da NFe 4.00, estou enviando para a seguinte URL: https://nfe-homologacao.sefazrs.rs.gov.br/ws/nfeinutilizacao/nfeinutilizacao4.asmx

Mas não está funcionando.

Erro:
Grave: com.sun.xml.messaging.saaj.SOAPExceptionImpl: Bad response: (400Bad Request
com.sun.xml.messaging.saaj.SOAPExceptionImpl: com.sun.xml.messaging.saaj.SOAPExceptionImpl: Bad response: (400Bad Request
at com.sun.xml.messaging.saaj.client.p2p.HttpSOAPConnection.call(HttpSOAPConnection.java:163)


Meu envelope está montado da seguinte forma:




Alguém está passando por isso também ou já passou por isso?

Obrigado.

Esta mensagem foi editada 1 vez. Última atualização foi em 30/04/2018 13:23:43

GGarcia

JavaC Membro
[Avatar]

Membro desde: 28/05/2013 17:12:21
Mensagens: 221
Offline

Boa tarde.

Quase certeza que o problema é o cabeçalho.

Por acaso sua variável CABECALHO seria


Se for, tenta remover.

Esta mensagem foi editada 1 vez. Última atualização foi em 11/04/2018 16:51:30


If you're here, who's running hell?
gilvangobbato

JavaC Membro

Membro desde: 16/07/2014 10:15:52
Mensagens: 21
Offline

GGarcia wrote:Boa tarde.

Quase certeza que o problema é o cabeçalho.

Por acaso sua variável CABECALHO seria


Se for, tenta remover.


Primeiramente, obrigado pela sua ajuda, desculpa pela demora em responder e fechar o tópico, realmente após ter sido resolvido o tópico foi esquecido.
Aproveitando então, a resolução foi parecida com o que você citou.

Dentro da variável "nfeDadosMsg" contem o xml com os dados da inutilização, porem nesta String também continha o cabeçalho "<?xml version="1.0" encoding="UTF-8"?>".
Então para resolver o problema foi removido o cabeçalho desta variável, mas mantido no xml do envelope para envio, ou seja, a estrutura da variavel "StringBuilder xml" foi mantida igual contendo o "<?xml version="1.0" encoding="UTF-8"?>" e o envio funcionou perfeitamente.

Mais uma vez, obrigado pela ajuda.
 
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Ir para:   
Powered by JForum 2.1.9 © JForum Team