Login Registre-se
Carta de Correção NFe 4.0 [Resolvido]  XML
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Autor Mensagem
GGarcia

JavaC Membro
[Avatar]

Membro desde: 28/05/2013 17:12:21
Mensagens: 204
Offline

Pessoal, boa tarde.

Hoje, como todos sabem, foram liberados os servidores de webservices atualizados para a NFe 4.0. Tirando um problema ou outro que encontramos e facilmente corrigidos, eu esbarrei em um problema interessante: absolutamente NENHUMA Carta de Correção está passando. Cancelamentos e Inutilizações funcionando corretamente.

Recebo o seguinte erro:



Estou enviando como versão 1.00, porque ainda não existe (pelo menos não achei) um Schema para a CCe 4.0.

Se eu tentar alterar a versão da CCe para 4.0



Esse é meu XML. Se deixar o atributo de evento como versão 4.00, recebe os dois erros acima. Se deixar como 1.00, recebo o primeiro erro. Se alterar o atributo de envEvento para 1.00 ou 4.00 realmente não faz diferença



Alguma ideia ou eu simplesmente esqueci de ler algo específico sobre a CCe 4.0? Estou validando o envio de acordo com o XSD CCe 1.0, único que achei para ela. Se eu tentar enviar o XML sem fazer a validação contra o XSD, recebo o erro 999 - Erro não catalogado.

Obrigado

Esta mensagem foi editada 3 vezes. Última atualização foi em 06/06/2018 10:17:19


If you're here, who's running hell?
marceel08

JavaC Membro

Membro desde: 03/10/2017 20:03:52
Mensagens: 12
Offline

GGarcia,

estou anexando um xml exemplo que uso para transmitir minhas cc-es para nfe 4.0

at
Marcel.
 Nome do arquivo cce.xml [Disk] Download
 Descrição cce
 Tamanho 5 Kbytes
 Baixado:  19 vez(es)

GGarcia

JavaC Membro
[Avatar]

Membro desde: 28/05/2013 17:12:21
Mensagens: 204
Offline

marceel08 wrote:GGarcia,

estou anexando um xml exemplo que uso para transmitir minhas cc-es para nfe 4.0

at
Marcel.


Obrigado pelo XML, marceel, mas ele é exatamente igual ao meu e não passa. Estou tentando pelo SEFAZ RS, mas nada até agora. Vou fazer mais testes. Estou usando o endereço de webservice de eventos da NFe4.

Valeu.

If you're here, who's running hell?
GGarcia

JavaC Membro
[Avatar]

Membro desde: 28/05/2013 17:12:21
Mensagens: 204
Offline

Update:

Removi a conferência do XML com o XSD enviei direto ao SEFAZ. Agora no final da tarde, passou. No início do dia eu recebia o erro 999.

Bom, com certeza erro nos servidores do SEFAZ.

Obrigado por enviar o XML para conferência.

If you're here, who's running hell?
robertop

JavaC Membro

Membro desde: 10/07/2013 20:08:36
Mensagens: 276
Offline

Boa tarde!

Efetuei um teste agora no link https://nfe-homologacao.sefazrs.rs.gov.br/ws/recepcaoevento/recepcaoevento4.asmx

Enviou normalmente.

A diferença que verifiquei no teu xml é que tu colocou versão 4.00 e estamos utilizando 1.00.

Esta mensagem foi editada 1 vez. Última atualização foi em 04/06/2018 18:04:44

GGarcia

JavaC Membro
[Avatar]

Membro desde: 28/05/2013 17:12:21
Mensagens: 204
Offline

robertop wrote:Boa tarde!

Efetuei um teste agora no link https://nfe-homologacao.sefazrs.rs.gov.br/ws/recepcaoevento/recepcaoevento4.asmx

Enviou normalmente.

A diferença que verifiquei no teu xml é que tu colocou versão 4.00 e estamos utilizando 1.00.



Eu tentei com 1.00 e 4.00. A minha versão de produção, liberada para clientes no final de semana, utiliza a versão 1.00 no XML e retornava o erro 999. Agora no final da tarde voltou a enviar. Menos mal.

Esta mensagem foi editada 1 vez. Última atualização foi em 04/06/2018 18:21:55


If you're here, who's running hell?
 
Índice dos Fóruns » NF-e / NFS-e / CT-e / CF-e / Certificados Digitais
Ir para:   
Powered by JForum 2.1.9 © JForum Team