Login Registre-se
Mensagens enviadas por: thiago oliveira
Índice dos Fóruns » Perfil de thiago oliveira » Mensagens enviadas por thiago oliveira
Autor Mensagem
Terça de manhã o sefaz começou a retornar um erro de fatura inválida mesmo sendo pagamento em dinheiro
hoje o erro mudou para erro de certificado alguém teve o mesmo problema pra sefaz de GO?
Lembrando que isso só acontece em homologação.

Connection has been shutdown: javax.net.ssl.SSLHandshakeException:
sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Roberto Valew cara deu certo, Muito Obrigado pela sua Ajuda
substitui essa linha


agora deu

cara no manual diz que não tem esse ultimo '|'
na verdade em uma parte diz que não tem e em outra diz que tem
entre o IDTOKEN e o CSC pode ser isso também
o meu caso eu não estou colocando!
Roberto o meu está desse jeito acho que o que está pegando e a URL continua a mesma ?
eu estava usando essa
mas no manual diz que é :
tmabém nos SCHEMAS que baixei hoje do sefaz parece que ele vaida nVersão 100
pode ser que esteja com schemas errados mas o que eu tenho é a versão PL_009_V4_NT_2016_002_v1_60b
você tem o exemplo do qrCode ? versao 2.0 ? e que possa postar por favor?
com o seguinte URL abaixo no qrCode retorna que está errado :/
Bom dia Roberto valew pela ajuda, acredito que essa parte esteja correto pois é a mesma usada na versão 1.0 e isso não deve mudar,
vi um erro no URL do sefaz, no caso peguei um errado e na verdade continua o mesmo que eu já estava usando vou corrigir e testar agora.
Bom dia pessoal, tive um problema na emissao da nfce com qrcode 2.0
utilizei o mesmo SHA-1 e geracao do hexadecimal da versao 1.0 acho que isso não seria o problema
mas minha url é essa porém acusa que está incorreto, alguém pode dar uma força?.
www.sefaz.go.gov.br/nfce/consulta/qrcode?p=52181001703877000101650010000017201000017204|2|2|195A44935E41D060029F7917B1147DA3FD9E7708B68D0644B9DBD4A7E
consegui pegar os sertificados startando o tomcat na pasta tomcat/bin/Tomcat8.exe
feito isso ele consegue achar os certificados normalmente, em um primeiro instante e a minha melhor solução, obrigado quem ajudou!.
entendi a sua implementação é exatamente o que eu preciso fazer, só não contava com esse problema do certificado uma vez que no desenvolvimento funcionou perfeitamente.
Na verdade esse é um servidor que recebe um arquivo gson e gera uma Nfe, o servidor rodará em windows e o certificado será instalado nesse servidor, quando debuguei o projeto
tudo rodou blz mas agora quando faço o deploy e mando gerar a NF-e o certificado não é encontrado isso acontece na mesma maquina que debuguei o projeto.
e seria isso mesmo preciso que pegue o certificado direto do servidor.
Não sou expert também em web, mas será que pode ser alguma modificação que tenho que fazer no tomcat?
Bom dia, tenho uma classe que pega os certificados digitais do repositório do windows justamente nessa linha

porém agora precisei criar um webservice que executa essa mesma classe, em swing ele retorna os certificados do repositório do windows
mas depois que criei o webservice e executo esse metodo ele não retorna nenhum certificado, dando um erro que nenhum certificado foi encontrado.
segue a classe completa.
Talves esteja falando besteira mas quando fui emitir NFC-e no MT tive um problema não lembro bem o que era mas corrigi ele mudando na classe NFeAutorizacaoStub.java
não custa nada tentar removi essa linha comentada que contém 'ns1' por "" não lembro se o erro era o mesmo, mas a NFe funcionava e o NFCe não.
 
Índice dos Fóruns » Perfil de thiago oliveira » Mensagens enviadas por thiago oliveira
Ir para:   
Powered by JForum 2.1.9 © JForum Team